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Exercice 2 : Transformations et combinaisons de 
données spatiales

Établissement d’une carte indicative des risques sismiques

Objectifs :

 Comprendre les principes et les enjeux de transformations élémentaires en 
analyse spatiale (polygon overlay, buffering)

 Appliquer une démarche systématique de transformation de données 
spatiales sur la base de critères thématiques.

LGB/GEOME – Cours SIG



Mise en contexte
Dans cet exercice, vous allez devoir établir une carte indicative des risques sismiques en suivant la  
démarche (légèrement simplifiée) appliquée dans le Canton de Vaud. 

Démarche pour l’évaluation de risques environnementaux 

1. Appréciation  du  danger  sismique,  c'est-à-dire  la  probabilité  qu’un 
événement  (aléa)  d’intensité  critique  survienne.  Cela  dépend  en 
particulier de la nature de l’assise géologique des sols : il faudra donc 
classifier le territoire en fonction de la sensibilité sismique du substrat 
géologique.

2. Identification de la sensibilité du territoire aux aléas sismiques : où un 
événement  sismique pourrait-il  générer  des  dommages ?  On imagine 
bien qu’un tremblement de terre menace plus une école qu’un champ de 
patates… Une source d’information pertinente est le plan d’affectation 
(PAF) de l’aménagement du territoire, qui traduit aussi bien les endroits 
où sont  les  infrastructures  critiques  que les  endroits  où l’on veut  en 
promouvoir la construction à court ou moyen terme. Il s’agira donc de 
classifier les zones d’affectation en fonction des dommages potentiels, 
et  de  sélectionner  les  plus  critiques  pour  la  suite  de  l’étude  (objets 
sensibles).

3. Pour  identifier  les  « secteurs  sensibles »  au  risque 
sismique,  on  se  base  sur  un  recoupement  de  la 
probabilité  d’un  événement  d’intensité  critique 
(danger) avec les objets sensibles aux dommages. On 
recoupe à cet effet les surfaces représentant les degrés 
de  danger  et  les  objets  sensibles,  et  les  « secteurs » 
résultants sont imputés d’un degré de sensibilité défini 
dans une table de combinaison définie sur des bases 
aussi bien politiques que scientifiques.
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4. Les  secteurs  sensibles  obtenus  doivent  être  considérés  avec 
beaucoup  de  réserve :  de  nombreuses  incertitudes  entachent  la 
procédure  d’évaluation  et  de  délimitation  des  zones  de  danger 
comme  des  objets  sensibles,  et  des  considérations  aussi  bien 
politiques que scientifiques entrent dans la table de combinaisons. 
Afin  de  tenir  raisonnablement  compte  des  incertitudes  dans  une 
perspective  de  précaution,  les  secteurs  sensibles  obtenus  sont 
« augmentés » d’une zone tampon dont l’épaisseur traduit aussi un 
compromis technico-politique !

Le résultat obtenu est une carte indicative des zones sensibles (secteurs sensibles augmentés d’une 
zone tampon de 100m),  établie  pour  l’ensemble  du canton à  l’échelle  du 1 :25'000.  Ces zones 
sensibles doivent ensuite faire l’objet d’une étude locale détaillée pour obtenir des cartes détaillées 
des sols de fondation, définissant les normes et obligations légales des constructeurs.
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Figure 1: Table de combinaison permettant de  
définir les secteurs sensibles



Données :

 PAF: fichier vectoriel (ESRI Shapefile) représentant le plan d’affectation.

 Sols_fondation: fichier  vectoriel  (ESRI  Shapefile)  représentant  la  classe  des  sols  de 
fondation.

 Zone: fichier vectoriel (ESRI Shapefile) contenant la surface entière couverte par la zone de 
travail.

 Cat_CADANAV.csv: fichier texte (CSV) indiquant les catégories  CADANAV  (Cadastre 
des  Dangers  Naturels  Vaudois).  Cette  table  lie  une affectation (selon le  PAF) avec une 
catégorie de sensibilité.

 object_categories.xlsx:  fichier  texte  (Excel)  indiquant  la  table  de combinaison entre  les 
catégories de sensibilité des objets du PAF et les codes SIA représentant les classes des sols 
de fondation. Les objets  included sont les objets les plus sensibles et les objets  excluded 
sont les objets les moins sensibles (cf. Figure 1). 

 paf_style.qml: fichier de style contenant une palette de couleur pour les éléments du PAF.

Question 1 : Ouvrez le fichier  Cat_CADANAV.csv avec un éditeur de texte ou Excel. Selon vous,  
quelle catégorie correspond aux affectations les plus sensibles en cas de séisme ? Quelles sont ces  
affectations ?

Question 2 : Ouvrez maintenant le fichier object_categories.xlsx. Suivant la réponse à la question  
1, quelles classes de sol favorisent les dégâts en cas de séisme ? 

Préparation du dossier de travail
1. Téléchargez le dossier de l’exercice depuis Moodle

2. Dézippez le dossier.

3. Ouvrez QGIS 3.28 (Desktop)

4. Créez un nouveau projet (Project > New) que vous sauvegarderez dans votre dossier de 
travail. 

Tout au long de l’exercice, enregistrez régulièrement le projet.
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Importation des couches
1. Importez le plan d’affectation (PAF.shp).  Choisissez la projection suisse CH1903+/LV95 

(EPSG 2056).

2. Importez  les  deux autres  couches  vectorielles  (Sols_fondation.shp et  Zone.shp)  qui  sont 
également définies dans la projection suisse CH1903+/LV95 (EPSG 2056).

Note : Si QGIS ne vous demande pas de spécifier le CRS de la couche lors de l’importation, cela  
est dû aux paramètres par défaut de l’application que vous pouvez changer dans Settings > Options 
en cochant les paramètres suivants :

 CRS for New Projects : « Use CRS from first layer added » 

 CRS for New Layers : « Prompt for CRS »

Classification du PAF
Nous allons tout d’abord attribuer une couleur différente à chaque affectation du PAF. Un code 
couleur spécifique est déjà défini et est disponible dans le fichier paf_style.qml.

Pour afficher une couche vectorielle avec une palette de couleur spécifique :

1. Clic droit sur la couche > Properties > Symbology (ici, la couche PAF)

2. Style > Load Style… (en bas de la fenêtre à gauche) 

3. Sélectionnez  le  fichier  de  style  .qml  dans  votre  dossier  de  travail  (ici,  le  fichier 
paf_style.qml)

4. Cliquez sur Apply puis OK.

La couche PAF devrait apparaître avec les nouvelles couleurs définies dans cette palette.

Lorsque l’on travaille  sur  une couche dans QGIS,  on peut  afficher  la  légende de la  palette  de 
couleur en cliquant sur la flèche à gauche de son nom dans la liste des couches. 

Il est difficile d’extraire des informations d’une telle carte. C’est pourquoi on aimerait lier chaque 
Affectation  à  une  Catégorie  de  sensibilité  comme  dans  le  fichier  Cat_CADANAV.csv analysé 
précédemment. 
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Jointure attributaire
Nous aimerions maintenant visualiser la catégorie de sensibilité correspondant à chaque zone de la 
couche PAF. Pour ce faire, nous allons créer une jointure attributaire qui permettra de « lier » la 
couche géométrique PAF avec la  table Cat_CADANAV afin d’importer dans la couche  PAF la 
catégorie de sensibilité correspondant à chaque zone. Nous aurons ainsi une nouvelle colonne dans 
la table d’attribut de la couche PAF dans laquelle la catégorie de sensibilité sera indiquée.

Pour ce faire, il est tout d’abord nécessaire d’importer le fichier texte  Cat_CADANAV.csv dans 
QGIS.

Pour importer un fichier texte dans QGIS :

1. Layer > Add Layer > Add Delimited Text Layer

2. Sélectionnez le fichier texte dans votre dossier de travail (ici, le fichier Cat_CADANAV.csv) 
puis cliquez sur Open.

3. Spécifiez si  nécessaire l’encodage des données dans le menu déroulant  Encoding.  Dans 
notre cas, nos données ont été encodées en ISO-8859-1 (souvent utilisé pour encoder des 
caractères latins).

4. Sélectionnez No geometry (attribute only table) sous Geometry type. 

Note : Un fichier texte pourrait contenir une géométrie (par exemple des coordonnées lat/long) mais 
ce n’est pas le cas du fichier Cat_CADANAV qui est simplement une table de correspondance.

Comme n’importe quelle autre couche,  Cat_CADANAV apparaît dans la liste de couche et vous 
pouvez la «lire » en faisant clic droit > Open Attribute Table. La seule différence par rapport aux 
autres couches est qu’il n’est pas possible de la « visualiser » dans la fenêtre principale de QGIS car 
elle ne contient pas de géométrie.

Afin de lier la couche  PAF avec la table  Cat_CADANAV, nous devons leur trouver un attribut 
commun (attention : cet attribut n’a pas forcément le même nom dans les deux couches, mais il doit 
contenir la même information). Ouvrez-donc la table d’attribut de  Cat_CADANAV, puis la table 
d’attribut de la couche PAF. Quel est l’attribut commun qui permettra de lier les deux tables ?

Pour créer une jointure attributaire dans QGIS :

1. Clic droit sur la couche géométrique > Properties > Joins

2. Cliquez  sur pour ajouter une nouvelle jointure.  

3. Spécifiez les paramètres suivants :

 Join layer : table contenant les informations à importer (ici, Cat_CADANAV).

 Join field : attribut de la table qui permettra de faire le lien.

 Target field : attribut de la couche géométrique qui permettra de faire le lien.

 (si nécessaire) Joined Fields : choix des attributs que l’on veut importer.
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 (si nécessaire) Custom field name prefix : définition d’un préfixe qui sera ajouté devant 
le nom de tous les attributs importés (dans notre cas, nous ne voulons pas ajouter de 
préfixe et vous pouvez donc effacer ce qui est écrit dans la case).

4. Cliquez sur OK.

5. (si  nécessaire)  Pour  rendre  cette  jointure  attributaire  permanente,  il  faut  sauvegarder  la 
couche  PAF  résultante  dans  une  nouvelle  couche  shapefile  (clic  droit  sur  la  couche 
PAF>Export>Save  Features  As).  Vérifiez  bien  que  le  format  est  ESRI  Shapefile  et 
désignez  votre  dossier  de  travail  comme  emplacement  de  sauvegarde  et  nommez  cette 
nouvelle couche PAF_cat.

On peut maintenant afficher le PAF avec une palette de couleur basée sur la catégorie de sensibilité.  
Changez la symbologie de la couche PAF_cat en attribuant une palette de couleur Reds à la colonne 
contenant la catégorie de sensibilité.

Question 3 : A quelle catégorie de sensibilité et affectation appartient l’objet du PAF avec l’ID  
53504 ?  Sur  quel(s)  type(s)  de  sol  est-il  implanté ?  Dans  quelle(s)  case(s)  du  tableau  
object_categories.xlsx se trouverait-il ?

Conseils  : Utilisez  l’expression  «  ID=53504 »  pour  sélectionner  l’objet  en  cliquant  sur 
Zoomez  ensuite  sur  l’objet  sélectionné  (voir  la  partie  Sélection  d’objets  dans  la  série 
d’Introduction). 

Pour obtenir les types de sol sur lesquels il est implanté, on peut utiliser l’algorithme  Select by 
location accessible via la  Processing Toolbox dans le menu Vector selection en sélectionnant les 
objets de  Sols_fondation qui  intersects PAF_cat. Cochez « Selected features only » pour obtenir 
uniquement les zones de sols qui sont en intersection avec l’objet sélectionné. Finalement ouvrez la 
table attributaire de la couche Sols_fondation et cliquez sur pour  identifier  rapidement  le 
CodeSIA des éléments sélectionnés.

Overlay
On aimerait maintenant automatiser cette analyse pour la reproduire sur chaque objet du PAF, ce 
que  nous  allons  faire  grâce  à  une  intersection  entre  les  couches  PAF_cat et  Sol_fondation. 
Commencez par désélectionner tous les objets des couches PAF_cat et Sol_fondation et créez une 
nouvelle  couche  paf_intersect_sol grâce  à  la  fonction  Intersection découverte  dans  la  série 
d’introduction.

Nous obtiendrons ainsi une nouvelle couche de sol, « découpée » par les bordures des zones du 
PAF.

Question 4 : Qu’avons-nous fait à cette étape ? Pourquoi ?
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Selon la table de combinaison object_categories.xls, les éléments avec les sols de fondation A, B et 
C sont exclus des éléments sensibles. 

Nous allons les sélectionner de manière automatique et les supprimer avec la démarche suivante :

1. Ouvrez la table des attributs de la couche paf_intersect_sol

2. Cliquez sur et utilisez l’expression « CodeSIA  IN ('A', 'B', 'C') » puis Close.

Note : Dans les expressions, les caractères doivent être entourés d’apostrophes, ce qui n’est pas 
nécessaire pour les valeurs numériques.

3. En choisissant Show Selected Features dans le menu déroulant en bas de la fenêtre, vérifiez 
que tous les éléments sélectionnés ont bien une catégorie A, B ou C.

4. Activez le mode édition puis supprimez les entités sélectionnées avec 

5. Triez les éléments de la table d’attribut selon le CodeSIA (en cliquant sur l’en-tête CodeSIA) 
et vérifiez qu’il n’y a plus de CodeSIA avec la valeur A, B ou C.

6. Sauvegardez les modifications avec 

7. Quittez le mode édition (en re-cliquant dessus)

Toujours en accord avec la table de combinaison, on peut également effacer les Catégories 1 et 2 
qui elles aussi ne sont jamais dans les zones sensibles primaires, et également les éléments de la 
Catégorie 3 avec les codes SIA E et D. 

Répétez donc les étapes 1 à 7 ci-dessus pour conserver uniquement les secteurs sensibles.

Zone tampon
Afin d’obtenir  les  zones sensibles,  nous allons maintenant  « augmenter »  de 100m les  secteurs 
sensibles, autrement dit créer une zone tampon (buffer) de 100m autour de ces polygones.

Pour créer une zone tampon (buffer) dans QGIS:

1. Vector > Geoprocessing Tools > Buffer

2. Spécifiez les paramètres suivants:

 Input vector layer: la couche sur laquelle créer la zone tampon (ici, paf_intersect_sol)

 Distance: la distance de la zone tampon (ici, 100)

 Choisissez l’unité de distance (ici, meters). Normalement, l’unité par défaut devrait être 
l’unité de distance de notre système de projection, qui est dans notre cas le mètre (pour 
la projection suisse). 

3. (si nécessaire) Cochez  Dissolve result. Cette option est recommandée lorsque l’on risque 
d’obtenir des polygones superposés, ce qui est le cas avec notre couche paf_intersect_sol. 
Avoir des polygones superposés peut rendre difficile la visualisation mais peut surtout poser 
problème lorsque l’on veut calculer la surface des zones tampons (comptage multiple)…

4. (si nécessaire) Buffered : sélectionnez le nom et emplacement de sauvegarde de la couche 
résultante (ici, nous la nommerons Zones_sensibles)
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5. Cliquez sur Run.

On  constate  que  les  polygones  des  couches  Zones_sensibles et  Zone ne  se  superposent  pas 
parfaitement. En effet, en ajoutant 100m autour de chaque polygone de zone sensible, on a obtenu 
des débordements en dehors de la zone d’étude ! Nous allons donc « couper » le résultat pour ne 
conserver que la zone sensible située à l’intérieur de la zone d’étude.

Pour « couper » une couche vectorielle selon une autre couche dans QGIS :

1. Vector > Geoprocessing Tools > Clip

2. Spécifiez les paramètres suivants :

 Input layer : la couche que l’on veut couper (ici, Zones_sensibles)

 Overlay layer : la couche que l’on va utiliser comme « emporte-pièce » (ici, Zone)

3. (si nécessaire) Clipped : sélectionnez le nom et emplacement de sauvegarde de la couche 
résultante (ici, nous la nommerons Zones_sensibles_finales)

4. Cliquez sur Run.

Question  5 : Calculer  le  pourcentage  de  zone  sensible  (en  utilisant  la  couche  
Zones_sensibles_finales) par rapport à l’ensemble de la zone. 

Question 6 : Que fait l’opérateur Buffer, dans quel but l’a-t-on utilisé ?

Question  7 : Dans  cet  exercice,  nous  avons  fait  une  jointure  attributaire  entre  une  couche  
vectorielle et la table CAT_CADANAV : En quoi consiste-elle ? Quelle serait la différence avec  
une jointure spatiale (que vous pouvez trouver dans Vector>Geoprocessing tool>Join attribute by  
location) ?

Question  8 : Complétez  le  schéma suivant  (diagramme de  processus).  Ajoutez-y  les  nouvelles  
couches créées et les principales étapes qui aboutissent à la couche « Zones_sensibles_finales ».
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