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1 Introduction

Most of the exercises of the Remote Sensing lecture will be using a software called QGIS
(Quantum Geographical Information System). QGIS is free and open source, version 3.10
is installed in the SIE computer rooms.

If you are working on your own computer, you can download QGIS from here.
IMPORTANT: If you do this, make sure that you download the Long-term release (cur-
rently version 3.40), for which the exercises are developed. This will make debugging
easier.

2 Starting the exercises

To start the exercises, follow these steps (for private laptops, you can of course save the
exercises and data where you please):

• If your are working on one of the EPFL computers, create a new directory named
RemoteSensing in your temporary hard drive Z:\. If you are working on your own
computer, create an appropriate directory which you will use for the different labs.
Make sure that no special characters (e.g. spaces, accents, ...) are in the path of this
directory: this could cause issues in QGIS.

• Download the data from Moodle and save it to your directory.

• Start QGIS Desktop, visible in the Start menu.

• Usually, the version of QGIS installed in the computer room is in French, but if
you wish you can change QGIS language from French to English in Preferences →
Options → Langue, check Forcer la nationalité du système and choose English.

• In the Browser panel, navigate to the path where your downloaded data is saved.
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• For this exercise, the Qgis2threejs plugin is needed. Make sure it is installed and
activated:

– Open the Plugins menu and select Manage and Install Plugins....

– Look for Qgis2threejs and tick it.

– Click on Close.

• Select the Save As... entry in the Project menu. Then, save the project in your
course directory. It will create a *.qgs file.

You are now ready to start the exercises !

3 QGIS Environment

3.1 Menus

When QGIS is fully started, you can see the menu bar at the top of screen. Underlying is
the toolbar, containing shortcuts for the most used functions.

Figure 1: The menu bar with the underlying toolbar.

Let’s have a look at these menus.

Project
Create, import and save projects. The print composer allows you to make printable
maps from the layers and to add legends to them.

Edit
Copy, cut, paste, add, remove, delete features and more from the current layers.

View
Select the view tool from Pan Map, Zoom, Identify Feature, etc. Select the interface
panels and toolbars.

Layer
Operations on the layers. Create, import, save or remove a layer. Manage layers
edits, update the properties such as the style and labels.

Settings
Change the QGIS settings, manage the layer styles and modify the Coordinate Ref-
erence System.

Plugins
Manage and install plugins.
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Vector
Contains a lot of different tools to work with the layers. Compute statistics, select
random features, intersect layers, calculate centroids and more.

Raster
Build new layers by working with pixel values from a rasterized layer. Rasterize
vector layers and more.

Database
Manage the databases (PostGIS, SpatialLite).

Web
We will use it to run the QGIS2ThreeJS plugin.

Processing
Run the Processing Toolbox, display the QGIS logs, more options. The Commander
can be activated to run algorithms or menu entries directly by typing a part of its
name.

Help
Help, API documentation, version number...

Remember that it is only a short overview. To have more information about the QGIS
interface, check the official documentation at https://qgis.org/resources/hub/.

A last tip: QGIS software is quite popular, if you are stuck with a project or do not know
how to achieve a certain task, look it up on Google! You are probably not the first person
in this situation and it is likely that the solution to your problem is explained somewhere
on the Internet.

3.1.1 File types

In this introduction, only a few file types were used.

Extension File type
∗.qml Style files (palettes, symbols, legends, ...)
∗.tif Raster data structure file (array of pixels, image)
∗.shp Vector file (array, see Shapefile for more information)

But a lot of other file types can be used. Almost all image format can be used to store
raster data structure, including but not limited to ∗.png, ∗.bmp, ∗.jpg, ... The advantage
of GeoTIFF (∗.tif extension) is that it also stores localisation information, such as the co-
ordinate reference system.

The most used file type to store geolocated vector data is the ∗.shp (ESRI Shapefile) file
type. The drawback of this file type is that besides the main .shp file additional files
are generated: the .prj file stores general projection parameters, the .qpj file stores addi-
tional QGIS specific parameters and the .shx file stores the metadata of the shapefile. This
means that if you want to copy the data somewhere else you have to take all files. GeoJ-
SON is maybe less known but it is a very simple open format using only one file, which
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can even be directly edited using a text editor. But other formats exists such as SQLite
∗.sqlite (SQLite database format) or Comma Separated Values ∗.csv for point data.

3.1.2 Coordinate Reference System

QGIS can work with a variety of different Coordinate Reference Systems (CRS). It can
be a problem if you load multiple layers with different CRS. If you can’t display a layer
(can’t zoom on it), it is probably because the layer’s coordinates are incompatible with
the current CRS. For example, if you are working with WGS 84 CRS and try to import a
file which is in CH1903+ CRS, you won’t be able to see it.

To avoid this problem, make sure all layers are using the same CRS. You can change it
in the General tab of a layer’s Properties. The conversion from a system to another will
then be done automatically.
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4 Getting started

4.1 Raster layers

Open the file rain clim.tif. You can load files by opening them in the Browser panel, or
by dragging and dropping them into the workspace. It will be added in the Layers panel.
You can click on the ”+” sign next to a layer to show its legend. Right click on the layer
and select ”set CRS” - ”set layer CRS” and select CH1903/LV03 / EPSG:21781. This sets
the coordinate system for the layer to the Swiss coordinate system.

By right-clicking on a layer and selecting properties, you can find more information on
the layer and access to its graphical rendering. When you open multiple layers, you can
choose which ones you want to be displayed by ticking them in the Layers panel. Since
they may not always be at the same position, you can move the camera to a particular
layer by right-clicking on it and selecting Zoom to layer. Layers at the top of the list will
be drawn above the layers below them.

1. Load the dem.tif file (set the CRS as for rain clim.tif), which is a Digital
Elevation Model, and look at the metadata: what are the minimum and maximum

elevations?

2. Check the information of rain clim.tif. What are the minimum and maximum
values? What do they represent?

As you can see, this file was automatically colored. This is because QGIS automatically
loaded the palette file with the same name rain clim.qml which was contained within
the same folder.

You can also make your own colorbar. Right click on the layer rain clim, select Properties
and go in the Symbology tab. Input the following values:

• Render type: Singleband pseudocolor
• Min: 0; Max: 11
• Interpolation: Exact
• Color ramp: Viridis, select from drop down menu, invert the color ramp
• Mode: Equal interval
• Classes: 12

Click on Classify and Apply. Unlike in the pre-loaded style, the labels for the colors are
no longer there. The layers legend can be seen in the layers panel by clicking on the ”+”
or ”arrow” sign next to a layer. The legend can be modified by going in the symbology
tab in the layer Properties. From here, you can for example rename one legend field by
right-clicking on it. Remember you will need to save the updated style. If you want it to
be automatically loaded when you open the TIF file, then give it the same name (minus
the file extension, which should be .qml and not .tif).

3. Look at the properties and legends of rain clim and dem. What type of data
contain these images ? How are they translated in the legends ?
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4. Estimate how much annual average precipitation falls in Geneva, Lausanne and
Basel, according to the legend in the .qml file.

5. Move the mouse cursor on the image. What happens in the Coordinate state bar
(bottom of the window) while moving?

The Histogram tab in properties allows you to see the histogram of the data. You can
zoom on it by drawing a square around the data while holding the mouse’s left button.
You can zoom back by right-clicking. To display the histogram with bars (QGIS by de-
fault option is lines), in the Histogram tab, click on ”Prefs/Actions” and uncheck the
”Draw as lines” option.

6. Describe the histogram of dem.tif. Why is there a larger number of values at the
lowest elevation?

Another useful button is the Identify Features tool.

7. What do you notice when you click on the map with this tool ?

4.2 Vector layers

Until now, we worked only with images, which are raster data structure. The other main
type of structures used in GIS is called a vector layer. Palettes are not usable with vector
layers. Instead, symbols can be displayed. Vector layers simply contain geographical (ge-
ometrical) definition of a set of spatial objects that are generally identified by an integer,
allowing them to be linked with their thematic representation. The most common file
extensions for vector data are .shp (shapefile) and .geojson, but also .dxf.

To see what a vector layer looks like, use the browser to import cantons.shp and make
sure it appears on the top of the layers list. Set the CRS to the Swiss coordinate system.
Right-click the layer and select Properties. In the symbology tab, you can select the vector
layer layout in the symbol properties. Select one and click on apply to see it on the image.

8. Now that you displayed a vector file, how would you characterize vector and
image (raster) representations? What are their advantages and disadvantages?

Arrange the layers, so that the canton boundaries are on top, then the precipitation and
at the bottom the DEM. Make use of the opacitiy setting in the transparency panel of the
layer properties, to show a combination of elevation and precipitation data, as well as the
superimposed cantonal boundaries.
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5 Palettes, symbols and text layers

In the previous exercises, we used different palettes and symbols without thinking about
how they were made. In this chapter, we’ll learn how to create them.

5.1 Palettes

The palettes are used to define colors for the different values of a raster layer. Colors are
often defined by RGB (Red-Green-Blue) triplets value ranging between 0 and 255.

• The quantitative palettes used to represent continuous variables (luminance, el-
evation, slopes, ...). A number of colors are defined for key values and a linear
interpolation is done between them to represent the continuity.

• The qualitative palettes used to represent discrete variables (soil occupation for
example). A color is used to represent a class and there is no interpolation between
the values.

In both cases, color palettes can be chose to be either sequential (over a range of colors) or
divergent (two opposing colors, usually merging through white). Sequential colormaps
are useful to show a progression of (positive) values, such as temperature or altitude.
Divergent colormaps help showing deviations, e.g. if white is centered at 0, and positive
values can clearly be differentiated from negative values.

We will now create a new palette for the raster layer dem. Right-click on it and open
the Symbology tab in the Properties menu. For a DEM, a continuous palette is generally
used. Insert the following values.

• Render type: Singleband pseudocolor
• Color interpolation: Linear
• Generate new color map: BrBG (tick Invert)
• Mode: Continuous

You can further modify the color ramp by double clicking the color ramp itself. Mod-
ify the color in the middle to a pale yellow and shift the ticks of the colors, so that it is
situated further to the left. This helps to show smaller elevation differences at lower alti-
tudes, e.g. in the Swiss plains.

If there are a few outliers in the raster, you can “discard” them from the color assig-
nation. Unroll the second bold menu ”min/max value settings” and tick the Cumulative
count cut (Bornes d’exclusion des valeurs extrêmes) and set the values to 2.5 and 97.5
to only keep the quantiles in between. Values outside of these defined quantiles will be
saturated to the colors of the extremes. Click on Load to set the new min/max values in
the fields above. Click on Classify to assign the colors to the values. As you can see, there
are only 5 values, which is normal because the colors will be interpolated between these
5 values.

If you are not satisfied with the classification, you can manually modify the values, the
colors and the labels. When you are finished, you can Apply the palette and save it using
Style → Save Style... (as type QGIS Layer Style File (*.qml)). If you give it the same name
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as the layer (minus the extension), it will be automatically loaded and applied next time
the layer is opened.

Discrete palettes do not interpolate the color in between values, rather the same color
is applied over a range of values. This is, what we experimented with for the rain clim
layer in the first section.

You can also apply a discrete palette to a DEM. This can be useful to show which part
of the map is above a given altitude but below another one for instance. To do so, you
can modify the continuous palette and set the color interpolation to Discrete instead of
Linear. If more colors are needed, a new color map can be generated with more classes,
or new lines can directly be added to the palette.

5.2 Symbols

Symbols are for vector layers what palettes are for raster layers. To illustrate this feature,
we will modify the cantons layer. Modify the canton boundaries in the symbology tab to
make them clearly visible.

5.3 Text layers

The next step to complete the map is to add the name of the cantons. To do this, a new
layer has to be added. From the Layer menu, open Create Layer and select New Shapefile
Layer.... Select Point as the geometry type. Line could be a good choice too because text
can be easily aligned along lines, but for this example we will keep the text horizontally
aligned. In the Fields list, select id and click on Remove field. In the ”New attribute”
field write “name” and click on Add to fields list. Click on OK and save it.

Continue by clicking on Toggle Editing and select the Add Feature tool. Click
on the center of each canton and enter its name as in Figure 2. When you’re done, click
again on Toggle Editing and Save the changes. Open now the layer Properties and set the
Transparency to 100% in the Style tab. Go to the Labels tab in properties and tick Label
this layer with name. Click on Placement and select Offset from point. Select the middle
button of the grid. Go back to the Text section. Select a Font, a Style, increase the text Size
(12) and choose a color. Apply the modifications and don’t forget to save the style.

If you want to export the layer as a .geojson (or another format) instead of the default
.shp, you can right-click on it and select Save As.... You can also make groups of layers.

To create one, click on Add Group in the Layers panel. It is now possible to move
layers inside that group and to show/hide them together in one click.

6 Making and printing maps

A nice feature available in QGIS is the possibility to make maps composed of multiple
layers, legends, titles, grids, etc. We will make a map displaying the dem layer, and the
canton borders from the cantons layer. Modify the colormap and labels of the dem layer
to provide a useful legend for altitudes, similar to the legend of the rain clim layer.
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Figure 2: Labelled cantons in Switzerland

Once you have loaded all necessary layers in your workspace and placed them in the
correct order, select New Print Layout from the Project menu, enter a name and click on
OK. Using the Add new map, Add new label, Add new legend, Add new scalebar and
Add new rectangle, try to make a map similar to the example for precipitation below in
Figure 3.

Each item added to the map is referenced in the Items panel. From there you can hide or
set layers priority as well as customizing them using the underlying Items properties tab.

You can now export or print the map. It would be a good idea to export it in SVG format
or another vector format. That way it is possible to zoom without losing quality (except
for the raster layers). If you want to save it and be able to modify it later, use the Save as
template button.

7 Calibration

When working with graphical layers, the values displayed in QGIS are between 0 and
255. It is fine for qualitative data, but most of the time it is not sufficient for quantitative
data, since the range is often not bounded to 255, or valuable information is lost, by ap-
plying a too large range.

Open the image pollen.tif and set the CRS to WSG84/Pseudo-Mercator / EPSG:3857.
In the symbology tab you can see that this is a multiband image, providing 3 bands (R,
G and B values). Try to adapt the color scales and min-max enhancement to visualize the
pollen on the lake clearly. Do not worry about maintaining correct coloring or contrast in
the rest of the image. Make use of the histogram and identify features tool to make good
choices for the range of values in each band.
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Figure 3: Example of map with precipitation data

In a second step, set the render type to singleband pseudocolor, use the spectral col-
orramp and isolate the signature of the pollen, while maintaining information in the
brighter areas by adjusting the percentiles of the colorramp.

This satellite image shows lake Geneva in spring 2020, where the very large amount of
pollen settling on the surface, made the rotating gyres visible.

Figure 4: Original satellite image, pollen barely visible

8 Perspective view and image wrapping

The maps made until now were only seen with an orthogonal view, but it is also possible
to represent them with a perspective view. For this, the Qgis2threejs plugin will be used.
First close all open layers then reopen the dem.tif and cantons.shp files. If the layer is not
visible, right-click and choose zoom to layer. Now select the Web menu on the top (Inter-
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Figure 5: Example of singleband pseudocolor palette to enhance pollen, while retaining information in
bright areas

net in the french version) → Qgis2threejs → Qgis2threejs and tick the dem layer, as well
as the canton boundaries. In Scene Settings set vertical exaggeration to 1, as horizontal
and vertical units are both in meters.

To change the display, it is possible to use a palette or to wrap an image over the ele-
vation model. To get a more realistic representation of the topography, we will wrap a
relief (hillshading) image. Go back to the main QGIS interface and open the Raster menu,
select Analysis and click on Hillshade.... Choose dem as Elevation layer and set the Out-
put layer to be a new file in the same directory (for example dem relief.tif). Leave the
Output format to GetoTIFF, Z factor to 1.0 and click on OK.

Open again the Qgis2threejs plugin. The visible layers are stacked on top of each other
in the order they are in the main layers panel of QGIS. You can either ensure that the
hillshade layer is on top of the dem layer in your layer panel, or right-click on dem inside
Qgis2threejs, select properties, tick layer image and select the hillshade layer.

Of course, you can also render vector layers on the top of the DEM and wrap other im-
ages representing different characteristics (trees, rain, population, etc). Try adding the
precipitation data and cantons next.

9. Try to modify the vertical exaggeration parameter in Qgis2threejs (within a
factor 2). In which context could it be useful ?

11



Figure 6: 3D rendering of DEM

Figure 7: Layered with hillshade graphic
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Figure 8: Layered with transparent precipitation data and canton boundaries
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