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Decision-aid methodologies in transportation – 

Transport modelling module – Lab 1 
 

Welcome to the second module of the Decision-aid methodologies in transportation course. In 

this module, we will focus on aspects of traffic and transport modelling. In the labs, we will 

mainly use Python and QGIS for the traffic network assignment. Traffic network assignment is 

the last step of a traditional 4 – step traffic model. However, it may be a bit tricky to set up, so 

we need to make sure that we can create a valid network in this first lab. 

 

1 Installing the required software 
 

In order to generate our data and run the traffic modelling analysis, we need the following: 

 

• QGIS (version 3.40.2 – Bratislava): Please download and install the file QGIS-

OSGeo4W-3.40.2-1.msi from: https://download.qgis.org/downloads/ 

• Python (version 3.11 or 3.12) 

 

2 Installing the necessary packages in QGIS 
 

Once QGIS is installed, we must also install the package that will do the traffic assignment for 

us. To do this follow these steps: 

 

1. On the Plugins menu, we click on Manage and Install Plugins… 

2. We choose the All (or Not installed) tab and in the search bar we type qaequilibrae and 

install the plugin. 

3. If we are asked for installing the missing dependencies, we click OK. 

4. We may have to restart QGIS to make the package work. 

5. If it still does not work we can try to deactivate and reactivate the package (using the 

tickbox before the package name) and restart QGIS 

6. More installation instructions can be found at: 

https://www.aequilibrae.com/latest/qgis/index.html 

7. If everything has worked well, we should see a new menu at the bottom left of the QGIS 

layout, as in Figure 1. 

https://download.qgis.org/downloads/
https://www.aequilibrae.com/latest/qgis/index.html
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Figure 1 QGIS screen after successfully installing the qaequilibrae package 

  

3 Preparing the network 
 

In transport modelling, we typically represent the road network as: 

 

• Zones: smaller areas of interest within our study area 

• Links: for representing the road segments 

• Nodes: representing the beginning and the end of a link 

• Centroids: to represent the centre of a zone where all trips start or end 

 

If there is no information available, we have to manually prepare the whole network of our 

study area. It is very likely though that someone else (e.g., our course instructor!) has already 

done this work for us. However, bad luck, they did this for whole Switzerland, but we only need 

a small part of it. For example, we want to focus our analysis on the city centre of Fribourg. 

Let’s see how to extract the information using QGIS. 

 

3.1 Importing the zones / centroids and extracting the study area 
 

The first thing we must do to is define the zones of our study area. Once we know the zones, 

we can also extract road network within our study area and exclude all other irrelevant network. 

Let’s start then! 

 

First, we must load the zones in QGIS. The easiest way, is to drag & drop the 

Verkehrszonen_Schweiz_NPVM_2017.shp file (in case you are wondering, this file is publicly 

available at: https://opendata.swiss/en/dataset/vm-uvek-zones-2017) anywhere in the QGIS 

area (later, we will also see some more elaborated ways of importing a layer). The result should 

look like Figure 2 — which, quite suspiciously, resembles Switzerland... But wait a minute, 

how can we extract the Fribourg zones in all this mess? 

 



3 

 

  
Figure 2 Loading the Switzerland zones shapefile in QGIS 

 

Before getting there, there is one more task that we must do first. Do you remember that each 

zone is supposed to have a centroid? Well, let’s load these ones too using the complex drag & 

drop method as previously. The shapefile with the centroids is 

Verkehrszonen_Schweiz_Zentroide_NPVM_2017.shp. If you did everything correctly, a lot 

(like a lot) of points should have been added to your QGIS project. Now, it’s time to extract the 

information related to Fribourg. 

 

 
Figure 3 Accessing the attribute table of a layer 

 

We can achieve this by opening the Attribute Table of the zone layer. If you right-click on the 

layer (as shown in Figure 3) you will see a menu where you can click and open the Attribute 

Table (Figure 4). 
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Now that we have opened the table, we must detect and filter the Fribourg entries. There is a 

lot of confusing and seemingly conflicting information on this table, but some kind person 

wanted to make our life easier and told as that the entries that we need are those where the 

ID_alt column value is 2196 (the same person also told us that for Lausanne, we need ID_alt 

= 5586, maybe it is something that we should keep in mind for the future). Now that we know 

the correct ID_alt value we simply do the following process: 

• Enable the Toggle editing mode (click on the yellow pencil button at the top left of the 

table or Ctlr+E) 

• Then, open the Select features using an expression button (click on the ε icon as shown 

in Figure 4) 

• In the expression window we type: ID_alt = 2196 and then click on Select features 

• We can now close the Select features window and the Attribute Table 

 

 
Figure 4 The Attribute Table of the zones layer 

 

If we have done everything correct, the city centre of Fribourg should be selected in our zones 

layer. We can save it as a separate layer as follows: 

• Right-click the zones layer in the Layers Panel. 

• Select Export → Save Selected Features As…. 

• Choose GeoPackage as the format. 

• Click Browse (the … icon) to choose where to save the new file. 

• Click OK. 

 

If we have done everything correctly, we can deactivate the zones layer (just untick the box in 

the Layers panel), and the result should be the centre of Fribourg surrounded by all these 

centroids (Figure 5). 

 



5 

 

 
Figure 5 The Fribourg zones 

Now it is time to keep only the centroids of the study area and get rid of all the other centroids: 

 

• Go to: Vector → Geoprocessing Tools → Intersection. 

• Set parameters: 

o Input layer → Select the points (centroids) layer. 

o Overlay layer → Select the Fribourg zones layer. 

• Click Run. 

 

If we have done everything correctly, we should see a new layer titled Intersection in the Layers 

panel. 

 

We are going to need this layer with the new centroids as an input for building our network 

model. The next task to do is to export as a csv file. However, let’s not be hasty and examine 

its attributes table first! This was a very good idea because there is a lot of information there, 

but not the coordinates of each point (one might say this is some important information to 

know). Luckily it is relatively easy and straightforward to get these: 

• Enable the Toggle editing mode (click on the yellow pencil button at the top left of the 

table or Ctlr+E) 

• Then, open the Field calculator (click on the abacus icon or Ctrl+I) 

• Create a new field as: 

o Output field name: x 

o Output field type: Decimal Number 

o Expression: x($geometry) 

• Click on the Apply button 

• Repeat the process for y (using the y($geometry) expression) and then press OK 

• Save edits (disk icon or Ctrl+S) and deactivate the editing mode (yellow pencil) 

 

Now we are finally ready to save and export the centroids! 

 

• Right-click the Intersection layer in the Layers Panel. 

• Select Export → Save Features As…. 
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• Choose Format: Comma Separated Value [CSV] 

• Click on browse and name your csv file as centroids_Fribourg.csv (or any other name 

that you prefer) 

• Click the OK button 

 

After doing all this process, we have created successfully (hopefully): 

 

• A GeoPackage with the zones of Fribourg 

• A CSV file with the centroids of the Fribourg zones and their coordinates 

 

3.2 Importing the nodes of the study area 
 

Next, let’s repeat the same process (more or less) to import the nodes of the study area. As a 

reminder the nodes are points that define the start and end of each link (road segment) and are 

unrelated to the zone centroids, which are a different type of point in our model. The modes for 

all Switzerland can be found in the nodes.csv file, so let’s import it! We can do this as: 

 

• Layer → Add Layer → Add Delimited Text Layer… 

• We browse (…) to the location of the nodes.csv file 

• In Geometry Definition we select Point coordinates 

• The x, y columns are most likely selected as X field and Y field automatically. If not 

then add them. 

• Geometry CRS: EPSG: 2056 – CH1903+ / LV95 (we are going to talk a bit later about 

the coordinate systems) 

• Click on the Add button 

 

This process is going to load many many points on our project and may be heavy for our 

computer. Let’s get rid of them by only keeping the points that we really need! 

 

We just repeat the same process as we did with the centroids before: 

 

• Go to: Vector → Geoprocessing Tools → Intersection. 

• Set parameters: 

o Input layer → Select the points (nodes) layer. 

o Overlay layer → Select the Fribourg zones layer. 

• Click Run (it may take a while this time). 

 

After the analysis is over, we close the Intersection window. We can then export to csv as: 

 

• Right-click the point layer in the Layers Panel. 

• Select Export → Save Features As…. 

• Choose Format: Comma Separated Value [CSV] 

• Click on browse and name your csv file as nodes_Fribourg.csv (or any other name that 

you prefer) 

• Click the OK button 

 

It is time now to prepare the links of our study area. Let’s do this in the next Section… But alas 

no! there is a couple more thing to add before we move forward and preparing our road network. 

What could they be though? Let’s see in Section 3.3. 
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3.3 The external zones and centroids 
 

3.3.1 Creating the external zones 

 

The study area, is – as its name implies – the main area of our interest. However, it is likely (it 

is actually certain) that we are going to observe traffic flows leaving our study area or entering 

our study area from an external zone. But which zone? We will keep things simple and assume 

a generic ‘external’ zone. This zone is not a ‘true’ traffic zone but it is generated out of 

convenience to absorb or generate all traffic flows that have one end out of our study area. This 

seems reasonable, however, there is a catch. If all the external traffic enters (or leaves) our study 

area from one location, we could congest our network in that area, and obtain some biased 

results that do not reflect reality. Instead, let’s create more (let’s say four) of these external 

zones. Later on, we will equally split the traffic generated or attracted to these zones (a strong 

assumption but definitely better than nothing). Let’s see how to do this in QGIS… 

 

If our project from Section 3.1 is still open we should have the Fribourg zones layer already 

loaded. If not, we have to imported (same drag & drop procedure as before). Now let’s click on 

the layer (in the Layers Panel) and then Toggle Editing (the yellow pencil icon we also used in 

the Attribute tables). This should activate the Add polygon feature (Figure 6). Let’s click on it 

(or Ctrl+.) 

 

Figure 6 Toggle Editing and Add polygon feature buttons 

 

Now the mouse cursor should look like a circle with a dot in it. We can navigate and create the 

external zones around our main study area (left-clicks to shape the zones and right-click when 

finished to confirm). 

 

When adding a new polygon QGIS is going to ask us to provide some input details (Figure 7). 

Let’s name our four new zones as 1, 2, 3, and 4 (give these values to fid, ID, and ID_alt). 

 

After adding the new zones, let’s save the layer (disk icon) and press again on the Toggle 

Editing button. The next step is to create the centroids for these zones. 

 

Tip: Try to be proactive when creating the external zones. In Section 4.4.2 we will create the 

centroid connectors i.e., some virtual links that connect the external zones to our main road 

network. Aim at placing the external zones close to a node of our main study area that will be 

used to connect the main study area with the external zone (e.g., in distance less than 500 m). 
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Figure 7 Adding the ‘external’ zones 

 

 

3.3.2 Creating the external centroids 

 

We are going to introduce the centroids as a new point layer (Figure 8): 

 

• Layer → Create Layer → New GeoPackage Layer… 

• We browse (…) to the save directory 

• Geometry type: Point 

• Coordinate Reference System: EPSG: 2056 – CH1903+ / LV95 

 

Now our new layer should be ready. Once again, we have to click on the Toggle Editing button 

but this time, instead of a polygon we add points. We name our points 1, 2, 3, and 4, same as 

we did for the external zones (make sure they match the names of the external zones as 

defined before!) 

 

Now, let’s also export these centroids as csv. Before doing so, we have to compute the x, y 

coordinates as we did previously (e.g., by adding a new x attribute with the x($geometry) 

expression – make sure you generate the new attribute as decimal!). 

 

As a reminder, we can export to csv as: 

 

• Right-click the point layer in the Layers Panel. 

• Select Export → Save Features As…. 

• Choose Format: Comma Separated Value [CSV] 

• Click on browse and name your csv file as centroids_Fribourg_external.csv (or any 

other name that you prefer) 

• Click the OK button 
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Figure 8 Creating the external centroids layer 

 

 

3.4 Preparing the links of the study area 
 

We finally have prepared all the input data and we can start preparing the links of our study 

area! This process is done outside QGIS. In this example we are going to use Python but we 

can really use any software that we feel comfortable with. The whole process is done in the 

Process_network.ipynb Jupyter notebook file that is provided on Moodle. In theory it should 

run without any problems as long as the paths to the necessary input data are provided correctly. 

However, let’s not be lazy and quickly examine what the script does: 
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• Most of the input is familiar to us (e.g., the centroid csv, node files etc.) however, we 

have not seen yet the links data. As its name implies, this file contains information about 

the links of the Swiss road network. 

• Qaequilibrae, the package that we will use for network assignment, expects data in a 

very specific format. In this file we begin preparing the data for this purpose. In case 

you notice some data processing that seems unexpected, is due to this reason. 

• For the links we need to consider the following: 

o We have to find the links within our study area. This is straightforward; for each 

link, we know the from (which node) and to (which node) information (the 

‘from’ node is also referred as ‘a’ and the ‘to’ node as ‘b’). Hence, we only keep 

a subset of links that have at least one from/to end that is part of the nodes of our 

study area. 

o We need to define the transport modes on each link. This is really a 

simplification of the original data that we do here. The modes are denoted by 

one letter as: cars (c), trucks (t), bicycles (b) and walking (w). For example, if a 

link is used by cars and trucks we type ‘ct’ (or ‘tc’, the order does not really 

matter). Buses, and public transport in general, is treated separately in 

qaequilibrae. 

o We need to give direction to our links (1: from a to b, 0: both ways, -1: from b 

to a). We have a one-way network; this means that direction is always 1 in our 

case. 

o For our labs, we will simplify things and ignore the rail network. For buses and 

trucks, we will assume that they occupy some proportion of the road network 

and we will not model them explicitly. 

• For the nodes we need to consider the following: 

o All nodes – both regular and zone centroids – must be in the same file. We need 

to define a is_centroid binary variable for the nodes that are zone centroids. 

o The ID of the centroids (and their respective zones) should start from 1. 

Whatever our original numbering is, we have to convert it in a way that the first 

zone starts from 1. In this example, the zones 1 – 4 will be the external zones 

and the first ‘real’ study area zone will begin from 5. 

o The nodes of the regular links cannot start from small numbers. However, they 

cannot be too large numbers either, because this causes a RAM allocation issue 

when using qaequilibrae. Hence, we begin the node numbering from 1000. 

Please note that this renumbering should be also done in the links data and create 

new from/to variables, but with the new id values this time. 

o We already know the nodes within our study area from the analysis that we did 

earlier in QGIS. However, some links may have one end (node) within and the 

other end (node) out of the study area. We do this check in the data and we add 

these nodes that are outside of our study area but they are parts of links with at 

least on end withing the study area. 

 

If we successfully run the Process_network.ipynb this means that we have all the data that we 

need to build our road network for a qaequilibrae project. It is time to move back to QGIS. 

Before doing so let’s confirm that we have the two new csv files: 

• nodes_Fribourg2.csv: contains both the link nodes and the zone centroids. ‘Fribourg’ 

refers to this specific example; it can be any name the user decides when saving the 

output. 

• links_Fribourg.csv: the links data of our study area. 
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4 Preparing the traffic model network in QGIS 
 

4.1 Importing the nodes and links layers 
 

After successfully running the Process_network.ipynb, it is time to prepare the network of our 

traffic model. It is finally time to use the qaequilibrae package. Before doing so, let’s import 

the new nodes and links file that we just generated. Importing the nodes is straightforward and 

we already covered this in Section 3.2. Be careful though! QGIS will automatically assign the 

is_centroid variable as Boolean (true/false). Before importing the nodes, change the variable 

to Integer, otherwise, it will not be possible to generate the traffic network. 

 

Importing and then properly visualising the links is a bit more complicated process. Let’s see 

how to do it below: 

• Layer → Add Layer → Add Delimited Text Layer… 

• We browse and find the links csv file 

• In Geometry Definition, we choose No geometry (attribute only table) 

• As previously, find the direction variable and change it from Boolean to Integer 

• Then we click on the ‘Add’ button 

 

We just imported the links data as a table. However, this table does not have a geographic 

representation yet. To do this, we need to do the following: 

 

• right click the links table layer → Export → Save Features As… 

• Change format to GeoPackage 

• Browse (…) to the desired path and give a name to the GeoPackage 

• Change the CRS to EPSG: 2056 – CH1903+ / LV95 

• Change Geometry type to LineString 

• Click on the OK button 

 

Note: it may be the case that the new created layer is not assigned a coordinate system (there 

will be a question mark next to the new layer in the Layer Panel. If this happens, click on the 

question mark and select: EPSG: 2056 – CH1903+ / LV95. 

 

Now, we can edit the geometry and properly visualise the road network. We can do this with 

the use of the Field calculator: 

 

• In the Layers Panel, we click on the links layer. 

• We click on the Toggle Editing button (the yellow pencil icon) and then we click on the 

Field Calculator icon (Figure 9).  

• In the Field Calculator, we tock the "update existing field" box 

• We change the field to "<geometry>" (it should be the last one) 

• We enter the expression: make_line(make_point("x1","y1"),make_point("x2","y2")) 

• If our coordinates have different names, we must replace the x1, y1 etc. names. 

However, the data that we generated in Section 3.4 should have the correct names. 

• We click on the OK button 

• We save the layer and deactivate the Toggle Editing mode 
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If we have done the process correctly, then we should see the road network visualised, as in 

Figure 10 (hopefully with some better colours in your case!). The next task is to convert the 

zones, nodes, and links layers to input for our traffic model… 

 

 
Figure 9 The Field Calculator icon 

 

 
Figure 10 Visualising the zones, nodes, and the road network 

 

… almost. It is finally time to talk about the coordinate system of our layers! 

 

4.2 Choosing the correct Coordinate Reference System (CRS) 
 

Before we actually convert our layers to the traffic network, we have to do one last tweak to the 

Coordinate Reference System (CRS) of our layers. You see, all data that we have imported and 

used so far are based on the Swiss coordinate system (what a surprise!) which you may 

remember when we previously imported layers as EPSG: 2056 – CH1903+ / LV95. The reason 

that we used this system is because all the raw data that we used to generate our layers were 

using this one. However, the AequilibraE module only works with the World Geodetic System 

(WGS 84). Hence, we have to convert the layers of the zones, nodes, and links to this system. 

Let’s see how to do this for one of the layers; the process is identical for all: 

 

• Right-click on the layer in the Layers panel → Export → Save Features As… 

• Change format to GeoPackage 

• Browse (…) to the desired path and give a name to the GeoPackage 

• Change the CRS to EPSG: 4326 – WGS 84 

• Geometry type: Automatic 
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• Click on the OK button 

 

After converting all three layers to the WGS 84 CRS, we are finally ready to move to the next 

step. I would suggest to completely close the current working project and start a new fresh one 

before moving to the next section. 

 

4.3 Splitting the nodes and centroids 
In the later sections we will have to define the centroids of the zones. This process can be more 

complicated than it sounds. To make our life easier, we will add one more step in the data 

preparation. In particular, we will split the current nodes layers (the layer that we transformed 

to the WGS84 system) into two layers, namely, the nodes (which are related to the links) and 

the centroids. As a reminder, the current nodes layer includes both. The process is relatively 

straightforward and we already implemented it when we selected the Fribourg zones among all 

Swiss zones. Here is a reminder: 

 

• Right-click on the nodes layer in the Layers panel and select “Open attribute table” 

• Enable the Toggle editing mode (click on the yellow pencil button with the yellow 

square under it at the top left of the table or Ctlr+E) 

• Then, open the Select features using an expression button (click on the ε icon) 

• In the expression window we type: is_centroid = 0 and then click on Select features 

• We can now close the Select features window and the Attribute Table 

 

This process has selected the nodes excluding the centroids. We save these as a separate layer 

as follows: 

• Right-click the nodes layer in the Layers Panel. 

• Select Export → Save Selected Features As…. 

• Choose GeoPackage as the format. 

• Click Browse (the … icon) to choose where to save the new file. 

• Give it a name such as nodes_only. 

• Click OK. 

 

Now we have to repeat the process for the centroids. The process is identical but to keep the 

centroids we have to set is_centroid = 1 in the Select features process. Name this second file as 

centroids_only. 

 

Now we can use the nodes_only file to generate our network nodes and the centroids_only file 

to generate the centroids of our zones. 

 

4.4 Converting the layers to the traffic model network 
 

4.4.1 Nodes and links 

 

It is finally time to create our road network. If we have started a new project, we have to import 

the zone, nodes, and links layers again (the ones using the WGS 84 CRS). In Section 4.2, we 

saved these as GeoPackages so we can simply drag & drop in QGIS, and they will be 

automatically imported. We start with the links and nodes (the process is simultaneous for 

both): 

 



14 

 

• In the AequilibraE panel → Model Building → Create Project from layers (if we have 

imported the correct types of layers, usually AequilibraE recognises them 

automatically). 

• We set the options for links as in Figure 11 and the options for nodes as in Figure 12 

(for the nodes make sure to select the nodes_only layer in the Layer option in Figure 

12 which excludes the centroids!) 

• We click on the Choose folder button and select the folder to save our project 

• We click on the Create Project button… 

 

… et voilà! Once the bar reaches 100%, the window will close and our project should be 

ready. Before moving forward though, there is something very important to keep in mind. 

Important! AequilibraE is an open-source package which is very convenient but also poses 

some challenges (like when trying to use any open-source software that some kind person 

prepared for us). That means that all the data preparation and input have to be done in a very 

specific way, otherwise, things will not work at best, or our whole project will crash and we 

will have to start from the beginning at worst. This is the reason that we have been giving 

specific ID values, using specific coordinate systems, or doing some steps in a very particular 

order. In case you face these issues, before getting upset or angry, just take a breath and a step 

back, check the previous sections, follow the instructions carefully, and things should be alright! 

 

Now that we clarified the very important thing to keep in mind, it is time to confirm that our 

project is (so far) correctly set up: 

• Deactivate or delete the layers of the nodes and links (keep the zones!) 

• In the AequilibraE panel → Project → Open Project 

• Click on the folder of your project (usually named new_project by default) and click on 

the Select Folder button 

• Nothing happens! (this is normal) 

• In the AequilibraE panel → Routing → Travelling Salesman Problem (please do this 

for real, this is the best way to visualise the road network…) 

• Close the window that just opened 

• The nodes and links should now appear as new layers! 
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Figure 11 The options for links 
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Figure 12 The options for links 

 

4.4.2 Centroid connectors 

 

We now need to add centroid connectors. As a reminder, the centroid connectors are links that 

connect the centroid of each zone to the road network. Centroid connectors do not necessarily 

represent an actual road of our road network but serve as virtual links: 

 

• In the AequilibraE panel → Model Building → Add centroid connector 

• We select the Layer option (The default is normally the From network option) 

• We make sure that the centroids_only layer is the one that we are importing from! 

• We select new_id as the identification variable. 

• We set the search radius to 500 or 1000 (it can be trial and error process). Better be start 

with 1000. 

• In the ‘Connectors per centroid’ option choose some value between 5-10. This is to 

avoid overcongesting the first actual link that connects to the zone connector. 

• We click on one of the options in the Allowed link types and then Ctrl+a to select all 

• We click on car, in Modes to connect 

• Then we click on the Add connectors button 

• Have a look at Figure 13 if you are uncertain about the options above 

 

Hopefully the progress bar reaches 100% without an error. As a quick check, we can try the 

following: 

• Access the attributes table of the nodes of the project. At the bottom of the table we 

should be able to find the centroids. The node_id of the centroids must start from 1. If 

not, the process did not work as expected and we should examine if the data that we 

used is correctly generated. 

paschali
Highlight
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• Investigate if some new links connecting the external zones to our road network are 

created. If there are no links between the external zones and the main study area, then 

we have to increase the search radius and repeat the process. 

 

 
Figure 13 The options for centroid connectors 

 

 

4.4.3 Add zoning data 

 

We now add the zoning data. The process is relatively straightforward but there is one more 

edit in the zones data that must be done first. As a reminder, the ID of the zones should start 

from 1 (this is how AequilibraE works!) and their IDs should match the values that we generates 

when processing the centroids while creating the nodes data. (Make sure you implement this 

process to the zones layer converted to the WGS84 CRS!) 

 

• We open the View → Panels → Processing Toolbox (or Ctrl + Alt + t) 

• In the Processing Toolbox → search “Order by expression” and access it 

• In the Expression area, we select: ID (leave sort ascending as is) 

• We click on the ‘Run’ button and then close the window 
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The process has created a new zone layer (most likely named Ordered). We select this layer in 

the Layers Panel and then: 

 

• Enable the Toggle editing mode (click on the yellow pencil button at the top left of the 

table or Ctlr+E) 

• Then, open the Field calculator (click on the abacus icon or Ctrl+I) 

• Create a new field as: 

o Output field name: zone_id 

o Expression: @row_number 

o Click on the Apply and OK button 

• We save the layer (disk icon) and deactivate the Toggle editing mode 

 

This process should have created a new zone_id variable starts begins from 1 and has sorted 

first the four external zones and then the ‘real’ zones of our study area. Once we have confirmed 

this, it is time to import these zones into our project. 

 

• In the AequilibraE panel → Model Building → Add zoning data 

• If the zones layer is imported, AequilibraE has most likely recognised it automatically 

(make sure you use the Ordered zones – in the Zoning layer option - that we just 

created!) 

• Select the zone_id in the zone_id option, and leave the rest as is 

• Click on the Process button 

 

You should see a bar loading and hopefully successfully reaching 100%. As usually, you will 

not see any changes in our project (we will see how to visualise zones later). Unless you receive 

an error message, the process is successful. 

 

Important! It is likely that all not AequilibraE options are visible by default. You can just 

extend the AequilibraE window at the bottom left until you see all the available menus. 

 

 

4.5 Checking network integrity 
 

In theory, by now we have created our project. The next step would be to load a demand matrix 

and extract the traffic flows. Before doing so (in a few weeks from now!), let’s first implement 

some sanity checks to ensure that our network is set up correctly and can be used. 

 

4.5.1 Shortest path 

 

First, we will start with the shortest path check. That is, we will select some origin and 

destination links and investigate whether a path between them can be found. Let’s see if this 

can be done both horizontally and vertically in our network. The external zones are good 

candidates for this task e.g., let’s see if we can go from zone 1 to 3 and from zone 2 to 4. We 

can do this as follows: 

• In the AequilibraE panel → Paths and assignment → Shortest path 

• We click on one of the ‘Configure’ button 

• We select: 

o Mode: car (c) 

o Minimize: distance 
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o Uncheck the box No paths through centroids (we want to allow traffic leave or 

enter from external zones) 

• Click Done! 

• In the Shortest path window: 

o From: 1 

o To: 3 

• Click on the Display button 

• Repeat for from/to 2 and 4 

 

If everything is done correctly, we should see the shortest paths between nodes 1 – 3 and 2 – 4 

highlighted on our map (Figure 14). You can also try different combinations of nodes to further 

check the network connectivity 

 

 
Figure 14 Shortest paths between the external zones 

 

4.5.2 Impedance matrix 

 

We will cover the use of impedance matrices in later labs. For now, let’s see if our model can 

generate one: 

 

• In the AequilibraE panel → Paths and assignment → Impedance matrix 

• Use the settings of Figure 15 and then click on ‘Compute’ 

• Repeat the process but instead of Centroids to centroids, select ALL nodes to ALL nodes 

(make sure the Block paths through centroids option is always unchecked) 
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Figure 15 Settings for impedance matrix 

 

We cam visualise the matrices that we generated as: 

• In the AequilibraE panel → Data → Visualize data 

• Select the matrix that we want to visualise and then click on the ‘Load matrix’ button 

 

As you may noticed, visualising the matrices automatically imported the zones layer of our 

project! 

 

5 Conclusion 
 

This concludes the first lab. So far, we have seen how to generate our zone and road network 

layers and import them as an AequilibraE. Moreover, we implemented some sanity checks to 

test the validity and connectivity of the road network of our project. Now that we are all set up, 

let’s see how to implement step-by-step all the stages of a 4 – step model. 


