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Important:
This document serves as a quick reference for performing the most basic operations in Cadence Virtuoso.
It is not intended as a step-by-step tutorial for designing a complete circuit from start to finish. The scope
is deliberately limited to the schematic and simulation stages; layout creation and post-layout analysis
are not covered here.

For a comprehensive guide that walks through the entire design process—from schematic to layout and
post-layout simulations (both digital and analog)—please refer to the following resource:

/education/tutorials/FullCustom Design

Pro Tip

In a Linux terminal, you can navigate to a directory using the cd command:

cd path to directory

To open a PDF file in a specific directory, use the evince command:

evince name of pdf file
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1 Library and Schematic Creation

1.1 Open the Library Manager

All operations (such as creating a new library, viewing, or modifying a schematic) begin from the Library
Manager, which functions similarly to a file explorer. When you start Virtuoso, the Virtuoso Terminal

opens by default. To access the Library Manager, navigate to Tools → Library Manager (Figure 1).

Figure 1: Open the Library Manager

1.2 Creating a New Library

To create a New Library, first open the Library Manager (Section 1.1). Next, open the Library

Creation Helper by navigating to File → New → Library (Figure 2). Enter the name of the library
(e.g., EE426 circuits) and click OK.

Figure 2: Opening the Library Creation Helper

A pop-up window like the one in Figure 3a will appear. Select the option Attach to an existing

technology library and click OK. Another pop-up will then appear (Figure 3b); select umc65ll (as
shown) and press OK. You should now see the newly created library listed in the Library Manager.

(a) Attach to a Technology Library (b) Select the Technology Library

Figure 3: Attaching the new library to an existing Technology Library
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1.3 Create a New Schematic

To create a New Schematic, first select the library in which you want to create the schematic. Then
navigate to File → New → Cell View. Configure the pop-up window as shown in Figure 4. Be sure to
select the correct Library and choose Schematic XL as the application for the view. Click OK, and the
schematic editor will open.

You can now begin creating your circuit by adding instances (Create → Instance, hotkey: i),
modifying their properties (hotkey: q) and connecting them with wires (Create → Wire (narrow),
hotkey: w) and allow a connection with some external sources and signals by adding pins (hotkey: p). A
complete list of useful hotkeys is provided in Section 1.3.1.

Figure 4: Create a New Circuit

When creating a new schematic, you primarily import and connect instances from different libraries
(e.g., basic electrical components such as resistors, capacitors, and transistors). In addition, you can also
import custom components that you have created in the current or other libraries. However, before these
circuits can be reused as components, a symbol must first be created for them (see Section 1.4).

By default, a number of libraries are available: some are provided by the tool itself, while others come
from the foundry design kit. The most important libraries in our case are briefly described below:

• basic: contains mostly graphical elements for circuit schematics.

• analogLib: includes many elements useful for simulation, such as voltage and current sources, ideal
resistors, capacitors, inductors, and switches. These cells are primarily used to create simulation
testbenches and simple analog circuits.

• umc65ll (Primitives Library): provides all the primitive devices (MOSFETs, resistors, capacitors,
inductors, etc.) from the UMC foundry design kit. When you design a circuit that, in a later stage,
will be printed, you should use the components inside this library

• UMC65LL UMK65LSCLLMVBBR B03PB (Standard Cell Library): contains the layout views from the
UMC foundry design kit. You do not need to use these cells, but they can serve as examples of how
standard cells are typically designed.

1.3.1 Useful Keyboard Shortcuts (Hotkeys)

A complete list of all the keyboard shortcut of the Virtuoso Schematic Editor can be found here.
Figure 5 summarizes them.
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Figure 5: Virtuoso Schematic Editor Hotkeys

1.4 Create the symbol associated to a schematic

To create hierarchical circuits and testbenches, you need to associate a symbol with each schematic. A
symbol is essentially a simplified view of the circuit in which only the pins are visible. When a circuit
is instantiated inside another circuit, its symbol is used as the graphical representation, allowing you to
connect it to sources and signals.

To create a symbol, open the Schematic Editor and select: Create → Cellview → From Cellview.
A first pop-up window will appear asking you to specify some options. The default values are usually

sufficient, so you can simply confirm by clicking OK. A second pop-up window then allows you to define
the location of the pins on your symbol. It is standard practice to place input pins on the left, output
pins on the right, and power/ground pins at the top and bottom. Once you are satisfied, click OK.

The Symbol Editor will then open, where you can shape and customize the appearance of the symbol.
When finished, perform a check, save your changes, and close the Symbol View.

2 Simulation Setup and Execution

2.1 Testbench preparation

The Testbench is basically the top level circuit where you are going to test the behavior of your circuit
under certain conditions. Normally, it contains the top-level module of the block you are designing
(basically the block itself) and some sources (to generate the input signals and to power the circuit) and
some loads (to simulate the interaction with the environment). Except for the blocks you designed, most
of the components present in the Testbenches are from the analogLib.

Pro Tip 1

Have a look at the Multiple-Bit Wire Naming Conventions to easily define multiple times the same
instance (multiple instances in parallel) and see how to connect wires to those instances. To create
busses, you can use the hotkey: Shift + w

Pro Tip 2

You can use labels as tunnel, so you do not need to route every connection! To insert a label, you
can use the hotkey: l (L)
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2.2 Create a maestro View

The maestro view is the Cadence Virtuoso view to run and handle simulations. In order to create the
maestro view, proceed with the following steps

• Choose Launch → ADE Assembler in the top-left corner of the schematic editor. A small window
will appear—select Create New View and click OK. If a Create New ADE Assembler View window
appears, simply click OK. Make sure that the view being created is of type maestro.

• The tool may notify you that it will obtain a different license than expected. This is normal, as
Cadence periodically updates and rebrands its licenses. Simply click Always to proceed.

Figure 6: Create a new maestro view - Steps

2.2.1 Variables (Parameters) Definition

Similar to programming, it is often useful to define variables instead of hardcoding values repeatedly in a
circuit. Using variables makes your design cleaner and simplifies simulation, as it provides a centralized
overview of all component sizes and factors. Additionally, it allows you to run multiple simulations with
different values without modifying the schematic itself.

Attention

The variables only work in the simulation domain! If you continue and start doing the layout you
have to specify the exact dimension of each component inside the schematic!

Defining a variable is straightforward. Let’s go through an example where we parametrize the value
(in Farads) of a capacitor inside a circuit:

• Select the instance for which you want to create a variable (in this example, select the capacitor
you want to parametrize).

• Open the instance properties (hotkey: q) and assign a variable name to the desired parameter. Use
clear and valid names (avoid starting with numbers or using special characters). For example, enter
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c in in the Value field. This associates the capacitor’s value (in Farads) with the variable c in,
meaning the capacitor will take whatever value is assigned to that variable.

• In the maestro view, expand the Global Variables menu and click on Click to add variable.
In the pop-up window, define the variable name and its value. For example, set c in = 1p to assign
a capacitance of 1 pF.

Figure 7: Setup variables in Cadence Virtuoso

2.2.2 Variable (Parameter) Sweeps

In many cases, you may want to run multiple simulations with different parameter values (e.g., varying a
capacitor size) and compare the results. Virtuoso provides an easy way to set up such parameter sweeps:

• In the maestro view, double-click on the value of the variable you want to sweep. A detailed view
of the variable settings will open (Figure 8a).

• Click on ... to open the sweep configuration pop-up.

• Remove any existing specifications by pressing Delete Spec until the window is empty.

• Using the selector in the top-right corner of the pop-up, choose the type of sweep you want to
perform. A simple From-To sweep configuration is shown in Figure 8b. For more details on the
available sweep options, click the Help button.

(a) Variable configuration window (b) Example of a From-To sweep setup

Figure 8: Defining parameter sweeps in Cadence Virtuoso
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Figure 9: Adding a new Test in Virtuoso

2.3 Configuring a Simulation

To run a simulation, you first need to create a Test within the maestro view and add it to the workspace.
Cadence Virtuoso supports multiple types of simulations (e.g., DC, AC, and Transient) that can be
configured within a test. To create a new Test, go to Test → Click to add test, as shown in Figure
9. A pop-up window will appear: select the circuit you want to simulate (typically your testbench) and
click OK. This will open the Test View.

Design Variables vs. Global Variables

In the maestro view, two types of variables are available: Global Variables and Design

Variables (defined inside a test).

• Global Variables: Shared across all tests within the view.

• Design Variables: Apply only to the specific test in which they are defined.

A useful feature is the option to right-click in the Design Variable section (inside the Test View)
and select Copy from CellView. This automatically imports all variables defined in the corre-
sponding cell view into the test. Note that this option is not available for Global Variables.

Once inside the Test View, you can return to the maestro view by clicking the blue arrow near the
test name (top-left corner). To rename a test, triple-click on its title (next to the blue arrow) and type
the new name.

Test View vs. maestro View

• Test View: Focused on a single test. It allows you to configure, run, and visualize simulations
related to that specific test.

• maestro View: Provides an overview of all defined tests. From here, you can compare
results across different simulations, although some test-specific features are not available.

Choosing the appropriate view depends on whether you want to work on a single test or analyze
multiple simulations together.

Once in the Test view, you should add an analysis. to do so choose Analyses → Clock to add

analysis (Figure 10).
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Figure 10: Add Analysis

Figure 11: DC Analysis Setup

2.3.1 DC Simulation Setup

DC simulations compute the steady-state voltages and currents in the circuit, providing a baseline for
further analysis (e.g. check if the polarization of the transistors in the circuit is correct).

To perform a DC simulation, first add an analysis (Figure 10). Then setup the pop-up as shown in
Figure 11. It is important to select the dc analysis and to check the Save DC Operating Point option.
Click OK. If you run the simulation from the Test view, you need to define all the variable again as the
Test view has no access to the Global Variables.

If you run the simulation from the Test view, you can now annotate the DC operating point (voltages
and currents) directly on the schematic by choosing Results → Annotate → DC node voltages. If
you want to see the internal parameters of some components (like the gm of a transistor) you can choose
Results → Print → DC Operating Point and select the component you want to inspect.

You can also run the simulation directly from the maestro view. Here you cannot directly plot on the
schematic, but you can check the value of some specific signal or expression (see Section 2.3.5 for further
details).
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Figure 12: AC Analysis Setup

2.3.2 AC Simulation Setup

AC simulations are used to analyze the frequency response of a circuit, including parameters such as gain,
phase, and impedance.

To set up an AC simulation, first add a new analysis (Figure 10). In the pop-up window (Figure 12),
configure the following:

• Set Frequency as the Sweep Variable.

• Choose the desired Sweep Range.

• Select the appropriate Sweep Type.

Figure 12 shows one example configuration. Once the parameters are defined, click OK.
You can now run the simulation directly from the Test View. To plot the results, go to Results →

Direct Plot → Main Form, complete the form as shown in Figure 13, and then click on the node of
interest in the schematic. The AC magnitude response will be displayed. Note that this plot shows the
absolute magnitude of the node voltage and is not automatically normalized with respect to the
input signal.

Alternatively, in the maestro view, you can define a custom expression such as:

dB20((VF("/Vout")/VF("/Vin")))

to plot the transfer gain. Be careful to match the variable and node names exactly.

2.3.3 Transient Simulation Setup

Transient simulations analyze the circuit’s response to time-varying signals, capturing dynamic effects
such as switching behavior, propagation delays, and waveform shapes.
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Figure 13: AC Plot Setup

To configure a transient simulation, first add a new analysis (Figure 10). In the pop-up window
(Figure 14), set the following parameters:

• Stop Time: Defines when the simulation ends.

• Accuracy: Controls the precision of the analysis (in most cases, moderate is sufficient).

An example configuration is shown in Figure 14. Once the parameters are set, click OK.
For transient simulations, it is often more convenient to plot signals directly from the maestro view

(click the blue arrow to return to maestro). See Section 2.3.5 for further details.

2.3.4 Noise Simulation Setup

Noise simulations are used to evaluate how different circuit components contribute to the overall noise
performance of a design. They provide key insights into parameters such as the total output noise, input-
referred noise, and the Noise Figure (NF) across frequency. This type of analysis is essential for validating
low-noise designs, such as LNAs or sensor front-ends, and for identifying the dominant noise sources.

To set up a noise simulation, add a new Noise Analysis (Figure 10). In the configuration window
(Figure 16), specify the following parameters:

• Set Frequency as the Sweep Variable.

• Define the desired Frequency Sweep Range.

• Choose the appropriate Sweep Type (e.g., linear or logarithmic).

• Select the Output and Input Noise Nodes. For single-ended configurations, set the negative
terminal to ground.

Once these parameters are configured, the noise simulation is ready to run. This analysis enables
the plotting of several important quantities, including the Noise Figure, input-referred and output noise
spectra, and total integrated noise over a given bandwidth. Refer to Section 2.3.5 for detailed instructions
on plotting simulation results in the Maestro environment.
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Figure 14: Example setup for a Transient Analysis

In addition to graphical plots, you can also generate a Noise Summary Report, which provides a
detailed breakdown of the main noise contributors at a specific frequency. To obtain this report, navigate
to:

Results → Print → Noise Summary

Then, select the instances to include (Include All Types is recommended) and specify how many top
contributors to display in the Truncate section. This feature helps identify which devices or circuit
sections dominate the noise performance. An example of the resulting summary output is shown in
Figure 15.

2.3.5 Plotting from the maestro View

Working in the maestro view can be very useful, as it allows you to plot signals and evaluate expressions
across different simulations. Figure 17 illustrates how to add a new signal for plotting.

The procedure is as follows:

1. Select the test of interest.

2. Choose whether to plot a signal or an expression (to simplify expression creation, you can use the
calculator via Tools → Calculator).

3. Once a new signal has been added to the view, double-click in the Details field and click the three
dots (...). This opens the schematic, allowing you to select the node or signal to plot.

4. When ready, click the green button at the top center of the window to run the simulation and
display results.
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Figure 15: Example setup for printing the Noise Summary
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Figure 16: Example setup for a Noise Analysis
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Figure 17: Adding and plotting signals from the maestro view
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